Trouble logging in to Unific.
Incident Report for Unific's
Resolved
This incident has been resolved.
Posted Apr 20, 2021 - 16:11 EDT
Update
We are continuing to investigate this issue.
Posted Apr 20, 2021 - 12:24 EDT
Investigating
Logins to Unific are failing due to a service provider being down. Currently investigating.
Posted Apr 20, 2021 - 12:24 EDT