Issues refreshing OAuth tokens.
Incident Report for Unific's
Resolved
This incident has been resolved.
Posted Nov 10, 2021 - 19:36 EST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 10, 2021 - 18:57 EST
Identified
The issue has been identified and a fix is being implemented.
Posted Nov 10, 2021 - 18:47 EST
Update
We are continuing to investigate this issue as a top priority. We've made some adjustments that allow tokens to refresh more often, however, we are experiencing timeouts when the tokens refresh. If a token is not refreshed in the 30-minute window, Unific will not be able to sync data to HubSpot until the token is refreshed. Thus you may see delays in the data sync and coupon generations.
Posted Nov 10, 2021 - 16:39 EST
Investigating
On Monday November 8th, Hubspot changed the length of time an OAuth token expires from 6 hours to 30 minutes. Many OAuth tokens are not refreshing within that 30 minute window. We are actively investigating the issue and working on a fix.
Posted Nov 10, 2021 - 10:03 EST
This incident affected: Order Sync, Contact Sync, and Dynamic Coupons.